wire version

Louis Moskowitz shared this problem 4 years ago
Known

Hi

I have just installed the new NoSQL booster for MongoDB. When trying to connect to a database that I have been using for a while with the old version (mongobooster) I am getting an error stating that the version of wire is 0 and Node.js requires at least 2. (MongoDB2.6)

The database is installed with the Ubiquity Unifi and I believe it is version 2.4.14 (Reported as th Server Version on the connection).

I have tried to install the latest version of Node.js as well to see if this corrects the driver version, but this did not help.


Thanks

Louis

Replies (1)

photo
1

MongoDB 2.4 reached end of life in March of 2016, MongoDB Node.js 3.x driver dropped support for MongoDB 2.4 or below. Beginning in NoSQLBooster for MongoDB 4.3, versions of MongoDB server prior to version 2.6 are no longer supported.


You can download 3.5.7 from the download page which supports MongoDB 2.2-3.4

photo
1

Hey there! Thank you for pointing that out. I tried downloading NoSQLBooster v3.5.7 and I am still getting an error. This time, NoSQLBooster can't even discover the replica set members.

---

{
	"message" : "no primary found in replicaset",
	"stack" : "MongoError: no primary found in replicaset" +
              "at /Applications/mongobooster.app/Contents/Resources/app.asar/node_modules/mongodb-core/lib/topologies/replset.js:555:28" +
              "at Server.<anonymous> (/Applications/mongobooster.app/Contents/Resources/app.asar/node_modules/mongodb-core/lib/topologies/replset.js:312:24)" +
              "at Object.onceWrapper (events.js:290:19)" +
              "at emitOne (events.js:96:13)" +
              "at Server.emit (events.js:188:7)" +
              "at /Applications/mongobooster.app/Contents/Resources/app.asar/node_modules/mongodb-core/lib/topologies/server.js:299:14" +
              "at /Applications/mongobooster.app/Contents/Resources/app.asar/node_modules/mongodb-core/lib/connection/pool.js:469:18" +
              "at _combinedTickCallback (internal/process/next_tick.js:67:7)" +
              "at process._tickCallback (internal/process/next_tick.js:98:9)",
	"name" : "MongoError"
}
When using NoSQLBooster v4.5.1, I was getting the same error as Louis Moskowitz.

---

{
	"message" : "Server at 127.0.0.1:42967 reports wire version 0, but this version of Node.js Driver requires at least 2 (MongoDB2.6).",
	"stack" : "MongoError: Server at 127.0.0.1:42967 reports wire version 0, but this version of Node.js Driver requires at least 2 (MongoDB2.6)." +
              "at /Applications/NoSQLBooster for MongoDB.app/Contents/Resources/app.asar/node_modules/mongodb-core/lib/topologies/server.js:377:39" +
              "at /Applications/NoSQLBooster for MongoDB.app/Contents/Resources/app.asar/node_modules/mongodb-core/lib/connection/pool.js:541:18" +
              "at _combinedTickCallback (internal/process/next_tick.js:131:7)" +
              "at process._tickCallback (internal/process/next_tick.js:180:9)",
	"name" : "MongoError"
}

Specifically about my setup:

I am connecting from a MacBook (macOS: 10.13.3)

Connection from my MacBook to MongoDB server (MongoDB Atlas) is going through a bastion server.

I can confirm that by installing mongo-org-shell (v3.6.3) on the bastion server and attempting to connect to the MongoDB server (v3.4.13) from the bastion server itself works without any issues.

I can also confirm that without using the bastion server as a SSH tunnel, I am able to connect to MongoDB server from NoSQLBooster v4.5.1. I can also discover the members of the replica set using the newer version of NoSQLBooster.


Kindly advise.


Thanks in advance!

photo
1

NoSQLBooster does not support connecting to replica sets via SSH. Although you can not connect to the entire replica set over SSH tunnel, you can still connect to one of the nodes to explore or manage your replica set. It is the same as you connect a stand-alone mongod server.

About this issue, please refer to this link. http://feedback.mongobooster.com/topic/ssh-tunnel-not-working#comment-623


The version 3.x supports MongoDB 2.2-3.4.

The version 4.x supports MongoDB 2.6-3.6.

photo
Leave a Comment
 
Attach a file