Mongo Atlas - Username containing an unescaped at-sign

Brendan shared this problem 4 years ago
Cannot Reproduce

I'm trying to connect to my mongo-atlas through NoSQLBooster.

I'm able to connect no problem with shell, however when I try to set it up and connect I'm getting this error. And this is even after I have escaped characters for my username & password already.

So this has to be an issue on the return route to NoSQLBooster

Help on this issue would be appreciated thanks.

btw my username on mongoatlas looks something

{"message":"Username containing an unescaped at-sign","stack":"Error: Username containing an unescaped at-sign\n at parseConnectionString (/Applications/NoSQLBooster for\n at parseHandler (/Applications/NoSQLBooster for\n at QueryReqWrap.callback (/Applications/NoSQLBooster for\n at QueryReqWrap.onresolve [as oncomplete] (dns.js:197:10)"}

Replies (1)


Thank you for your feedback.

1) atlas, I tried to add an user "" to my atlas test database. but got such error: The username "" is invalid. Usernames can only contain ASCII letters, numbers, hyphens, and underscores, and should begin with a letter or number


2) I also tried with my local mongodb 4.0 db, it works.


Leave a Comment
Attach a file