Cannot read property 'Mquery_ext_methods' of undefined

Joshua Wiens shared this problem 3 years ago
In Progress

Can not connect to Atlas Replica set in v4.7 +

Works fine in 4.6, broken in 4.7 as well as 5.0 which means i'm stuck running 4.6 on a mounted .dmg because there is not way to prevent the auto update for constantly breaking my query editor.


8bf5656d941a364a938a0e4b1e2a2c0c

Replies (5)

photo
1

Please backup and delete your user data and try it again.

1. Open NoSQLBooster, click Menu-> Help-> Open User Data Directory

2. Close NoSQLBooster

3. Backup and Remove User Data Directory. <NoSQLBooster for MongoDB>\*.*

4. Re-run NoSQLBooster

photo
1

Issue remains following the above directions on Version 5.0.0


nosqlbooster version: 5.0.0 Enterprise

Mongos version: 4.0.4 Atlas Replica Set


I've tried connecting with every applicable role with the default database set.

photo
1

Thank you for your feedback. I still can't recall the issue, I can only try to fix the problem by guessing the error code.

We have worked out a test build to try to resolve the issue, please download and give it a try.

MacOS: https://nosqlbooster.com/s3/download/releasesv5/nosqlbooster4mongo-5.0.1-beta.1.dmg

photo
1

That build is at least a step in the right direction. I can connect ( have to use the Atlas Admin Account ) and run basic queries though as you can imagine, using the service level admin account is less than optimal.


Would it be helpful if I supplied a small Atlas database and a set of users with various roles to aid in troubleshooting these issues?

photo
1

Thanks, please send the accessible MongoURI and test credentials to support@nosqlbooster.com

Leave a Comment
 
Attach a file