UI freezing v7.0.5

Arno Reinhofer shared this problem 2 years ago

After running a simple find() query in the editor, the UI completely hangs and is not responding.

I made a video from that behaviour:


I'm using the free version 7.0.5 on a Windows 10 machine.

I already tried to click away all performance related options, didn't help.

I tried with different MongoDB clusters -> same problem

Another fact: If I run the script with CTRL+ENTER, the UI is fine until I hover over the first line!

Replies (2)


in the meantime I have an idea why this happened:

I copy/pasted a really really big script into the editor, with 50000 numbers in an $in clause.

And I think after that the editor was somehow broken. Although I deleted the cache, and all open tabs where closed.

After I deleted the AppData/Roaming folder, the same query is now OK again.


It may have something to do with the writing of historical scripts. We will add some defense code in future versions.

Leave a Comment
Attach a file