Most fields show up in NoSQLBooster as null, or do not appear at all

jessica shared this problem 45 days ago
Cannot Reproduce

I have a collection I've tried to import a million different ways (through mongoimport in terminal as json and as csv, and directly through NoSQLBooster via both mongoimport and plain import, as json and csv). The problem is the same every time: most fields in my data either do not show up in NoSQLBooster at all, or they show up as having "null" values. I know that these fields exist and contain data, because I can see them in the mongo shell. I cannot understand how I can view the same collection via the shell and see data there, but NoSQLBooster shows those same fields as null or nonexistent.

I am viewing data via Localhost, on the new version of NoSQLBooster (7.0). However, I tried to import this same collection one time before switching to the new version, and I had the same problem. All other collections are displaying properly.


UPDATE: This may be a problem with my data -- the shell was only displaying entries that were working properly. You can mark as resolved or delete!

Replies (1)

photo
1

I have no way to reproduce the problem locally, nor can I guess the cause of the problem.


If you're reporting a bug, please make sure you include steps to reproduce it.


1. NoSQLBooster Version e.g. 7.0.2

2. Operating System e.g. macOS 10.13.6 / Windows 10 1803 / Ubuntu 18.04

3. Expected Behavior

4. Actual Behavior

5. How to reproduce, please include your sample JSON data to import.

6. Screenshots

Leave a Comment
 
Attach a file