Open Mongo Shell / NoSqlBooster CLI

John Polansky shared this problem 56 days ago
Solved

Hey,

I've been trying to explore the following features:

046db95d93ca09108a2d5d3aaf9cd2eb

However I can't seem to get either to work:

Setup:

c0e3b58ec4753bfa5da1085a48190467

/usr/local/opt/mongodb-community@4.2/bin/mongo --version
MongoDB shell version v4.2.9
git version: 06402114114ffc5146fd4b55402c96f1dc9ec4b5
allocator: system
modules: none
build environment:
    distarch: x86_64
    target_arch: x86_64


Trying to open either of them after setting the path and enabling the nbcli results in nothing but periodic message like this:


ad056fd4637cf04b2dba6af6661d20a0

I noticed the warning mentions "Terminal" I primarily use "iTerm" but Terminal is still installed and I was able to open both tools inside Terminal from the command line.

Replies (4)

photo
1

We have only tested a clean macOS system. This compatibility problem caused by other software is difficult to reproduce, so it is difficult to solve.

If you're reporting a bug, please make sure you include steps to reproduce it.

photo
1

@qinghai - I'm sorry I thought I had included the steps to reproduce but I agree I could have made them more clear. I was mostly asking how to setup up this feature. Here are some steps:

1. Install 6.2.17

2. Access the 023a09df721dca81a5e85c4e72f496e3 under Options menu

3. Follow the dialog to set the path. note that the path does not allow you to put in a path unless it contains a "mongo" binary

4. then try and execute the mongo shell feature (nothing happens 1-2 mins later the Terminal warning pops up.


You mentioned you tested this on a "clean macOS system" I'm not sure I understand this. To my knowledge Mongo tools are not installed on macOS so you can't use this feature that way. May I asked what method and packages you use to test this feature? Brew install, Manual install? Part of my question is to ask "how" this feature should be utilized, As far as I can tell I followed the dialog prompts correctly.

I realize there are complexities involved in using an app with an unlimited amount of possible customization, but NOSQLBooster does not appear to be provide any useful error messages to troubleshoot the issue. If you believe the issue is my non-standard OSX I understand but I still think we have a bug in that the app is not properly providing the user with appropriate feedback to resolve the issue?

I'm happy to retest if you could please give me your test configuration for a "clean osx" + "mongo-tools".

photo
1

In internal, we use "osascript" to open the "mongo" cmd line. The code is as follows

const osa=require("run-applescript");
await osa(`tell application "Terminal" to activate`);
console.log("osa command line", osaCmd);
await osa(`tell application "Terminal" to do script "${theCmd}"`);

Please run NoSQLBooster in command line to print the complete "osa command line".

  1. Open terminal.
  2. cd /Applications/NoSQLBooster for MongoDB.app/Contents/MacOS
  3. ./NoSQLBooster\ for\ MongoDB

photo
1

Chuckle well guess what I went to try your method of startting NoSQLBooster from terminal and mongo shel did open this time. So I quit out and started NosQLBooster from the Application menu and again mongo shell opened up this time. I'm not honestly sure what has changed .. So I guess good news is this appears to be working. Bad news I need to open a bug as it doesn't appear to be passing the correct configuration to the shell as it's not including the SSL option to `Accept any server SSL/TLS Certificates` so it fails to connect if I add on `--tls --tlsAllowInvalidCertificates` on to the shell command it works fine.


Thanks for the help sorry for the false alarm.

Leave a Comment
 
Attach a file