UI Freezing

Mihai Ionut shared this problem 3 months ago
Solved

Hello.

I'm using NoSQLBooster on macOS, on 3 different machines - a 16 inch i7 Macbook pro, a 13 inch i5 Macbook pro and an Apple M1 Mac mini.

All 3 machines exhibit the same behavior - frequent freezes. I've tried disabling and enabling every performance option available, including hardware acceleration, yet the same thing - every few minutes, the interface just freezes with for some time (I estimate about 20 to 30 seconds). During this time clicking on anything does nothing, but when the interface is responsive again, it "replays" all clicks.

I am a paying user with 1 license (I use the 13 inch mbp just occasionally, and this runs the free version, yet the same thing happens).

I usually use 2 or 3 connections to RS servers, each one having a few hundred databases with 100 collections each. The data set is usually large, but even using limit to 20 records and disabling cursor count does not help.


Please tell me if there's anything to try as it is starting to really annoy me, almost to the point of being unusable.

Replies (10)

photo
1

Just from the written description, I can't guess what the problem is. This kind of problem-related to the specified system cannot be reproduced locally, so it is difficult to trace and debug.

If you're reporting a bug, please make sure you include steps to reproduce it. And, please enable developer mode to collect information for diagnostics.

1. cd /Applications/NoSQLBooster for MongoDB.app/Contents/MacOS


2. NODE_ENV=dev ./NoSQLBooster\ for\ MongoDB

1. NoSQLBooster Version e.g. 6.2.15

2. Operating System e.g. macOS 10.13.6 / Windows 10 1803 / Ubuntu 18.04

3. Expected Behavior

4. Actual Behavior

5. How to reproduce, include a sample JSON data and MongoDB script to reproduce the error quickly


6. Screenshots

photo
1

Hello and thank you for your response.


This is exactly what I was asking for, further steps (like starting with the development console) to help solve this.

1. NoSLQBooster version 6.2.15, but this also happens in 6.2.14 down to 6.2.10 (didn't test lower than that)

2. macOS Big Sur 11.4 (same behaviour on all dot versions of Big Sur, from 11.1) - both Intel and Apple Silicon.


3. UI should not freeze for 20 seconds every few minutes.

4. UI freezes every few minutes for 20 or 30 seconds, although it seems to register clicks as it "replays" them after unfreezing

5. To reproduce - just open a few collections and switch between the tabs. I cannot provide sample JSON data, as I didn't test this on sample data - nor do I really care if this happens or not on a small sample of data. I work with mongo servers running hundreds of GB of data and it should work as expected. I also cannot provide sample data - this is live production data, multiple servers with hundreds of databases and collections.

6. I hope you realize that an UI freeze cannot be showcased with screenshots, right?


I've made a video showing this behavior, with the debugging console active.

https://youtu.be/z0uMsd-yw-4


Starting from 30 seconds into the video you can see the freeze and how it unfreezes at 1:01.


Tell me if there's anything else you need.


Thank you.

photo
1

Dunno if it helps, but the console (command line) shows lots of:

[2611:0708/075816.172004:ERROR:CONSOLE(109)] "Uncaught (in promise) Error: Could not instantiate: ProductRegistryImpl.Registry", source: devtools://devtools/bundled/shell.js (109)

photo
1

Ok, I've done a bit more testing.

On a test server (same config, RS with one arbiter) with just 2 databases having a few collections each everything works as it should. Even generating 1 million records in a test collection and loading lots of tabs with that collection there's no slowdown or freeze.

It seems to me as the freeze is generated from the left (connection tree) pane - there's something wrong in handling a server with 800 databases with 100 collections each.

This is definitely a bug of sorts, as it is not just a slowdown - maybe that I would have understood. But a complete freeze is not ok. (not to mention studio 3t has absolutely no slowdown with this).

Maybe have an option to limit the left pane to just one "current" database? Like when searching, to restrict the list to the search database.

photo
1

I simulated thousands of databases and thousands of collections but still couldn't reproduce the issue.

Excuse me, are there many fields in the collections?

You can turn off the options below and try again.

a5e8896af6bdff64b4d840566c32733e

photo
1

Already turned off, everything from that menu, including Auto Fetch Cursor Count. I even tried disabling hardware acceleration, to no avail.

Yes, the documents are usually large - as in 20 to 30 top level fields, some of which are objects or arrays.

A typical document "tree" has 100 to 200 "leafs".

photo
1

Thank you for your feedback.

We have worked out a new test build to resolve this issue, please download and give it a try.

MacOS: http://s3.mongobooster.com/download/releasesv6/nosqlbooster4mongo-6.2.17-beta.1.dmg

photo
1

Thank you!

Indeed, it seems this is working properly.

Please allow me to do some more testing (and actual real work) and I'll get back to you in a day or two with the final answer.

Btw, I presume the fix will be available in the next official release, right? (as in 6.2.17).


Thank you again.

photo
1

Yes, the fix will be available in the next release.

photo
photo
1

Perfect.

Mark this as solved, everything is working as it should.


The whole app is now actually faster then before, even when it was not freezing.

Great support. I would definitely recommend NoSQLBooster!

Leave a Comment
 
Attach a file