SSH tunnel won't connect

Todd J. Barlow shared this problem 3 months ago
In Progress

When I configure a connection to use a SSH Tunnel, it never gets to a point where the tunnel is connected. It just sits there and never times out (I've waited 10+ minutes).

It doesn't matter which IP address/options I use, it's always the same.

This is all I ever see in the "Test Connection" window:

12:11:15.899  *** Starting "Connect to SSH Server" ***
{"askForPassword":false,"authMode":1,"password":"******","port":22,"server":"<server>","username":"<username>"} 

As stated above, this happens on both of my MBPs running NOSQLBooster for MongoDB v6.2.15. I have co-workers that have a very similar setup and it works fine. I am at a loss as to what to check, as a manual SSH connection works fine.

Replies (5)

photo
1

I did some quick tests. As shown in the following figure, it works well.

The connection problem is difficult to solve because I have no way to reproduce the problem locally. Please make sure your ssh account works on the command line first.

fb1b74435650cb7c7c17abb80cd84ad2

photo
1

As stated, it all works well outside of this program. I've watched when I make the test connection call, and I see sub processes launch, but I never see any actual new TCP connection trying to be established. You honestly have no additional ways to debug/troubleshoot this problem? As I've stated, it happens on two different MacBook Pros. It's not isolated. Except for some particular configuration somewhere.

Can you give me insight into how the SSH connection is supposed to be established? I am assuming a built-in library? Does it rely on anything else on the system? It's not a showstopper for me, but it would make my life easier if I could use this feature.

photo
1

[I tried to edit my above comment, but it didn't work]

I was incorrect, I do see the connection to the remote SSH server. However it's immediately closed. The confounding part is that the window is not updated to reflect any error. In one case I just put a 127.0.0.2 as the SSH server and I still see nothing:


1ac336edc5e03da2dc474d43e9fe85b6

However, when I put a random IP address into the Mongo server address I DO see error messages.


Somehow the SSH errors are just not being displayed in the window?

photo
1

[FIXED] The problem ended up being the format of my private key file used. However, still note that SSH connection errors are NOT shown in the dialog. I found the version of ssh2 node.js module you were using and reproduced the issue. Once that worked properly w/ my private key I tested it again.


NOTE: Newer versions of the SSH2 node.js module (1.1.0) support more key formats; you may want to upgrade.

photo
1

There is indeed an SSH authentication error that can not be properly recorded and handled. We will fix the issue in the next build. And, we do use the SSH2 package and we will sync SSH2 module to the latest version in future updates.

Leave a Comment
 
Attach a file