Editor appears to not type 'm M' character when url fields

John Polansky shared this problem 3 years ago
Cannot Reproduce

I've had a weird issue driving me nuts for awhile.. and I think i finally sorted it out. Let me assure you I tested my keyboard outsides of NoSQLBooster it has no issues with the 'm' key

When you are using the "editor" to edit a field value, and the "current" value makes NSB think it's a url like "test.log" it creates a small popup saying u can click 'p' character. While this popup is visible it appears to block typing the 'm / M' character.

As I'm sure you'd guess this is very annoying since it causes you to make a lot of typos. is there some sorta hotkey blocking the 'm' input?



Obviously u can't see me trying to type the 'm' key but trust me I am furiously pounding it.. notice the popup dialog indicating NSB thinks this is a URL. if I wait a few seconds for the popup to disappear and click 'm' again (without leaving edit mode) boom it works 100% so i'm assuming some sorta hot key issue is conflicting.

NSB Version: 6.1.4

OSX: 10.15.6 (19G2021)

Steps to Reproduce:

  1. Create a new collection
  2. db.new_collection.insert({key: 'test.log'})
  3. Now do a find and display the view in Tree or Table and double click the 'test.log' value, notice the popup and try typing an 'm or M' character.. it shouldn't work

Thanks love your product please help me from making typos :)

Replies (1)


I tried it several times locally.

But it is still not possible to reproduce the problem.


Are you seeing the popup in question? I'm confused why it isn't happening for you when it easily does for me. I just tried and reproduced it again.

What do you suggest I try to help provide?


Following your steps, I can't reproduce the problem locally.

Alternatively, you can click the edit button on the right to open the full editor.



Hrm, ok u sure u didn't sneak a fix in to 6.1.5?

I just retested multiple times and I'm not having an issue with the M character as you can see


Well I guess we can close the ticket.. Thx!


We didn't fix the bug on purpose because we couldn't recall this issue at all :)

Leave a Comment
Attach a file