Error when connecting on AWS since 7.xxx

Walid AZIZ shared this problem 25 days ago
In Progress

Since version 7.x I have the following message when try to connect do DocumentDB on aws

option ssl_ca_certs is not supported

Version: 7.0.4


OS: {"platform":"darwin","type":"Darwin","release":"21.1.0","mem":"8G"}


License: Personal 311163


Brief:

Connect to docdb-prod.cluster-cm1s9pf6ziut.eu-west-3.docdb.amazonaws.com Status:Failed Duration:

Build SSH tunnel to ec2-35-181-14-76.eu-west-3.compute.amazonaws.com:22 Status:OK Duration:


Error:

"option ssl_ca_certs is not supported"


Details:

11:05:07.148 *** Starting "Connect to SSH Server" ***

{"askForPassword":false,"authMode":2,"keyPath":"/file.pem","passphrase":"******","port":22,"server":"XXXXX.eu-west-3.compute.amazonaws.com","username":"zzzz"}


11:05:08.982 *** Finished "Connect to SSH Server" 1,825 ms***

{"askForPassword":false,"authMode":2,"keyPath":"/file.pem","passphrase":"******","port":22,"server":"XXXXX.eu-west-3.compute.amazonaws.com","username":"zzzz"}


11:05:08.984 *** Starting MongoClient.connect ***

{"uri":"mongodb://user:******@localhost:49872/hortus?authSource=admin&ssl=true&ssl_ca_certs=rds-combined-ca-bundle.pem&servername=docdb-prod.cluster-yyyy.eu-west-3.docdb.amazonaws.com","options":{"sslValidate":false,"promoteLongs":false,"promoteValues":false,"maxPoolSize":2,"minPoolSize":1,"appName":"NoSQLBoosterV7.0.4_11039.703","directConnection":true,"sslCA":"/rds-combined-ca-bundle.pem"}}


11:05:08.993 *** Connect Error ***

"option ssl_ca_certs is not supported"

Leave a Comment
 
Attach a file