Open MongoDB Shell does not appear to be passing correct SSL options

John Polansky shared this problem 3 months ago
Known

noSQLBooster 6.2.17

Using a Mongo Server configured with SSL and the following configuration

  {
    "name": "localhost",
    "uri": {
      "database": "npm",
      "hosts": [
        {
          "host": "localhost",
          "port": 27017
        }
      ],
      "options": {
        "authSource": "admin",
        "replicaSet": "rs_pronghorn",
        "ssl": true
      },
      "password": "XXXXX",
      "scheme": "mongodb",
      "username": "admin"
    },
    "colorFlag": "none",
    "authMode": 1,
    "connectionType": "replica",
    "certRelated": {}
  },
noSQLBooster connects perfectly in the GUI as it has the options to 'Accept any server SSL/TLS certificates' however notice the config above does not appear to reflect that. If i attempt to start a mongo shell it fails


/usr/local/opt/mongodb-community@4.2/bin/mongo 'mongodb://admin:admin@localhost:27017/npm?authSource=admin&replicaSet=rs_pronghorn&ssl=true'
MongoDB shell version v4.2.9
connecting to: mongodb://localhost:27017/npm?authSource=admin&compressors=disabled&gssapiServiceName=mongodb&replicaSet=rs_pronghorn&ssl=true
2021-08-31T11:49:12.623-0500 I  NETWORK  [js] Starting new replica set monitor for rs_pronghorn/localhost:27017
2021-08-31T11:49:12.624-0500 I  CONNPOOL [ReplicaSetMonitor-TaskExecutor] Connecting to localhost:27017
2021-08-31T11:49:12.653-0500 E  NETWORK  [ReplicaSetMonitor-TaskExecutor] SSL peer certificate validation failed: Certificate trust failure: CSSMERR_TP_NOT_TRUSTED; connection rejected
I'm not sure if the GUI assumes a default of ignore SSL or what but it appears that option isn't being passed down to the mongo shell execution.

Leave a Comment
 
Attach a file